summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..11e40a8
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,26 @@
+# $XdotOrg: $
+
+AC_PREREQ([2.57])
+AC_INIT(xhost,[7.0], [xorg@freedestkop.org],xhost)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+AC_TYPE_SIGNAL
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(XHOST, x11 xmu)
+AC_SUBST(XHOST_CFLAGS)
+AC_SUBST(XHOST_LIBS)
+
+# Transport selection macro from xtrans.m4
+XTRANS_CONNECTION_FLAGS
+
+# Secure RPC detection macro from xtrans.m4
+XTRANS_SECURE_RPC_FLAGS
+
+AC_OUTPUT([Makefile]) \ No newline at end of file