summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-11 01:09:43 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-11 01:09:43 +0000
commit9c8787d2ce69e55b9ba362a92f01592d8ee0a3a3 (patch)
tree4250d9d774d1bd2cda386be451ccb918da27866f /Makefile.am
parente2dd25d3cf2f10c0cff0d37d05f58b81344db68b (diff)
Don't define HAS_COOKIE_MAKER if mcookie wasn't found.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e9bd22..46e1a5f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,7 @@ xinitrc: xinitrc.cpp
$(SED) s/XINITDIR/`echo $(XINITDIR) | sed -e s/\\\\//\\\\\\\\\\\\\//g`/ < $(srcdir)/xinitrc.cpp | $(SED) s/XCOMM/\#/ > $@
startx: startx.cpp Makefile
- $(RAWCPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) -DHAS_COOKIE_MAKER -DMK_COOKIE=$(MCOOKIE) $(srcdir)/startx.cpp | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ | $(SED) -e 's/@@/\\/' > $@
+ $(RAWCPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) $(STARTX_COOKIE_FLAGS) $(srcdir)/startx.cpp | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ | $(SED) -e 's/@@/\\/' > $@
xinitrc_DATA = xinitrc