summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-08-29 01:54:30 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-08-29 01:54:30 +0000
commit9f74cfed8f808009b3acfa0af383218f3bf0fc00 (patch)
treeb2bf5d33d780221b8dfb6f39895ff7b4a35b613c /Makefile.am
parent52fb36b1ec52e78916bf9cf1a5e7bdce05482b0c (diff)
Define HAS_COOKIE_MAKER and search for mcookie so startx will generate
xauth tokens for the servers it starts.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 152331d..6e9bd22 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,7 @@ xinitrc: xinitrc.cpp
$(SED) s/XINITDIR/`echo $(XINITDIR) | sed -e s/\\\\//\\\\\\\\\\\\\//g`/ < $(srcdir)/xinitrc.cpp | $(SED) s/XCOMM/\#/ > $@
startx: startx.cpp Makefile
- $(RAWCPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) $(srcdir)/startx.cpp | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ | $(SED) -e 's/@@/\\/' > $@
+ $(RAWCPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) -DHAS_COOKIE_MAKER -DMK_COOKIE=$(MCOOKIE) $(srcdir)/startx.cpp | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ | $(SED) -e 's/@@/\\/' > $@
xinitrc_DATA = xinitrc