summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@apple.com>2011-04-25 22:17:25 -0700
committerJeremy Huddleston <jeremyhu@apple.com>2011-04-25 22:17:25 -0700
commit567f59d3f8189b92bc46e2af1260f9340f462bdb (patch)
tree616cc330338ffbf010d9e404190bef0ebc08aaa1 /Makefile.am
parent75a969b884296439fb84ca2be8f77d718d7da1e6 (diff)
launchd: Reorganized layout of launchd sources
Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 2b8a4eb..2ba7364 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,23 +59,17 @@ CPP_FILES_FLAGS = \
-DLAUNCHD_ID_PREFIX="$(launchdidprefix)"
if LAUNCHD
-$(launchdidprefix).startx.plist.cpp: org.x.startx.plist.cpp
- cp $< $@
-
-launchagents_PRE = $(launchdidprefix).startx.plist.cpp
-launchagents_DATA = $(launchagents_PRE:plist.cpp=plist)
-
-SUBDIRS = privileged_startx
+SUBDIRS = launchd
endif
-DIST_SUBDIRS = privileged_startx
+DIST_SUBDIRS = launchd
xinitrc_DATA = xinitrc
MAINTAINERCLEANFILES = ChangeLog INSTALL
CLEANFILES = xinitrc startx $(appman_DATA) $(launchagents_DATA)
-EXTRA_DIST = xinitrc.cpp startx.cpp org.x.startx.plist.cpp $(appman_PRE) \
+EXTRA_DIST = xinitrc.cpp startx.cpp $(appman_PRE) \
autogen.sh
.PHONY: ChangeLog INSTALL