summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 21:12:01 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 21:12:01 +0000
commitd731a249d0c1c7f9eb77828c0d6e79cfdaf75589 (patch)
treeeba35096db8e4c27dfb17f8b4ace46ccc751fac6 /Makefile.am
parentdd7fee44b126636d6c3edd9e325ce411e3ae5d78 (diff)
Build system for xinit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..50903dd
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,50 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+XINITDIR = $(libdir)/X11/xinit
+
+bin_PROGRAMS = xinit
+bin_SCRIPTS = startx
+
+xinit_CFLAGS = $(DEP_CFLAGS) -DXINITDIR=\"$(XINITDIR)\" -DBINDIR=\"$(bindir)\"
+xinit_LDADD = $(DEP_LIBS)
+
+xinit_SOURCES = \
+ xinit.c
+
+dist_man_MANS = \
+ startx.man \
+ xinit.man
+
+xinitrcdir = $(XINITDIR)
+
+xinitrc: xinitrc.cpp
+ $(SED) s/XINITDIR/`echo $(XINITDIR) | sed -e s/\\\\//\\\\\\\\\\\\\//g`/ < $< | $(SED) s/XCOMM/\#/ > $@
+
+startx: startx.cpp Makefile
+ $(CPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) $< | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ > $@
+
+xinitrc_DATA = xinitrc
+
+CLEANFILES = xinitrc startx
+
+EXTRA_DIST = xinitrc.cpp startx.cpp \
+ startx.cmd xinitrc.cmd xinit.def