summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-11-10 04:25:39 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-11-10 04:25:39 +0000
commit277975ec73744657e556a0c6380614d8684db7df (patch)
tree465503c121858ce59f6aaf1aa6331d4462d7245e /configure.ac
parent6e7bcf4f2ea8bb868ed8b0459f1c0d6cc172f4ae (diff)
Add settings for SHELL_CMD & ARCHMANDEFS to match monolith changes for bugXORG-6_99_99_902
#3180. AC_DEFINE(XORG,...) so it is listed as available server in xinit help output. Update cpp -D flags to match monolith changes for bug #3180.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9896bf1..e89500b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,24 @@ if test x$MCOOKIE != x ; then
fi
AC_SUBST(STARTX_COOKIE_FLAGS)
+# Additional substitutions in xinitrc & man pages
+case $host_os in
+ *sco*)
+ SHELL_CMD="/bin/ksh"
+ ARCHMANDEFS="-D__SCOMAN__"
+ ;;
+ *)
+ SHELL_CMD="/bin/sh"
+ ARCHMANDEFS=""
+ ;;
+esac
+AC_SUBST(SHELL_CMD)
+AC_SUBST(ARCHMANDEFS)
+
+# Defines which X servers are listed in help output in xinit.c
+# Cheat, lie, and assume all the world is Xorg for now
+AC_DEFINE(XORG, 1, [Define if you have Xorg X server])
+
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION