summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston Sequoia <jeremyhu@apple.com>2021-03-10 13:46:23 -0800
committerJeremy Huddleston Sequoia <jeremyhu@apple.com>2021-03-10 13:46:23 -0800
commitdb21df4054e3351d14eb7dc1c3216cd23a61cee4 (patch)
treee2543b635559158df7ee9e0866d4d1f86c651a7f /configure.ac
parente2430bcb8327682340d985f89ad5137efa2f0d4f (diff)
darwin: Drop support for macOS 10.7 and earlier
Signed-off-by: Jeremy Huddleston Sequoia <jeremyhu@apple.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 3530b7e..b0a22b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,26 +117,12 @@ if test "x$LAUNCHD" = "xauto"; then
AC_CHECK_PROG(LAUNCHD, [launchd], [yes], [no], [$PATH$PATH_SEPARATOR/sbin])
fi
-TIGER_LAUNCHD=no
-if test "x$LAUNCHD" = "xyes" ; then
- AC_DEFINE(HAVE_LAUNCHD, 1, [launchd support available])
- case $host_os in
- darwin8*)
- TIGER_LAUNCHD=yes
- ;;
- esac
- AC_CHECK_FUNC(dispatch_async,
- AC_DEFINE([HAVE_LIBDISPATCH], 1, [Define to 1 if you have the libdispatch (GCD) available]),
- [])
-fi
-
AC_DEFINE_UNQUOTED(BUNDLE_ID_PREFIX, "$bundleidprefix", [Prefix to use for launchd identifiers])
AC_SUBST([launchagentsdir])
AC_SUBST([launchdaemonsdir])
AC_SUBST([bundleidprefix])
AC_SUBST([launchagentxserver])
AM_CONDITIONAL(LAUNCHD, [test "x$LAUNCHD" = "xyes"])
-AM_CONDITIONAL(TIGER_LAUNCHD, [test "x$TIGER_LAUNCHD" = "xyes"])
AM_CONDITIONAL(LAUNCHAGENT_XSERVER, [test "x$launchagentxserver" != "xno"])
# Checks for pkg-config packages