summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Nusinow <dnusinow@debian.org>2008-02-05 11:58:40 -0500
committerDavid Nusinow <dnusinow@debian.org>2008-02-05 11:58:40 -0500
commitb9a2f211eff9f7fdc1399146d175923ca589cf2a (patch)
tree76d803af03db4d4c56140902fed8f4457cb2b344 /configure.ac
parent6403e53a1fef9fd7dd8c77640d01bb8aaee09f91 (diff)
Unbreak installs on non-launchd systems
Thanks to cjb for running the tinderbox that spotted this breakage.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index df672aa..2a364ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,7 +98,6 @@ AC_ARG_WITH(launchagents-dir,AS_HELP_STRING([--with-launchagents-dir=PATH], [Pat
h to launchd's LaunchAgents directory (default: /Library/LaunchAgents)]),
[ launchagentsdir="${withval}" ],
[ launchagentsdir="/Library/LaunchAgents" ])
-AC_SUBST([launchagentsdir])
if test "x$LAUNCHD" = "xauto"; then
unset LAUNCHD
@@ -121,7 +120,9 @@ if test "x$LAUNCHD" = "xyes" ; then
esac
else
AM_CONDITIONAL(APPLE,false)
+ launchagentsdir=""
fi
+AC_SUBST([launchagentsdir])
AM_CONDITIONAL(LAUNCHD, [test "x$LAUNCHD" = "xyes"])
# Checks for pkg-config packages