summaryrefslogtreecommitdiff
path: root/launchd/Makefile.am
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremy@yuffie.local>2007-12-16 01:12:20 -0800
committerJeremy Huddleston <jeremy@yuffie.local>2007-12-16 01:12:20 -0800
commitcced740b1e1c8220701e59cec1be04498f851296 (patch)
tree8ec8a2cd170282ceef7bc420cbe396db24605a1b /launchd/Makefile.am
parent3c5ae3a242895f53d4f27fefb785f2725077a55d (diff)
OS-X: Added argv[0] hack for finding Xquartz UI and icon as well as claiming its dock icon
Partially removes need for x11-exec on OS-X. We still need to handle options set in defaults.
Diffstat (limited to 'launchd/Makefile.am')
-rw-r--r--launchd/Makefile.am15
1 files changed, 0 insertions, 15 deletions
diff --git a/launchd/Makefile.am b/launchd/Makefile.am
deleted file mode 100644
index b841df8..0000000
--- a/launchd/Makefile.am
+++ /dev/null
@@ -1,15 +0,0 @@
-if APPLE
-libexec_PROGRAMS = x11-exec
-x11_exec_LDFLAGS = -framework CoreServices
-endif
-
-launchagents_PRE = org.x.X11.plist.pre
-launchagents_DATA = $(launchagents_PRE:plist.pre=plist)
-
-CPP_FILES_FLAGS = \
- -D__libexecdir__="$(libexecdir)" \
- -D__bindir__="$(bindir)"
-
-CLEANFILES = $(launchagents_DATA)
-
-include $(top_srcdir)/cpprules.in