summaryrefslogtreecommitdiff
path: root/launchd/user_startx/Makefile.am
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@apple.com>2011-04-25 22:17:25 -0700
committerJeremy Huddleston <jeremyhu@apple.com>2011-04-25 22:17:25 -0700
commit567f59d3f8189b92bc46e2af1260f9340f462bdb (patch)
tree616cc330338ffbf010d9e404190bef0ebc08aaa1 /launchd/user_startx/Makefile.am
parent75a969b884296439fb84ca2be8f77d718d7da1e6 (diff)
launchd: Reorganized layout of launchd sources
Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
Diffstat (limited to 'launchd/user_startx/Makefile.am')
-rw-r--r--launchd/user_startx/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/launchd/user_startx/Makefile.am b/launchd/user_startx/Makefile.am
new file mode 100644
index 0000000..9e4e4d9
--- /dev/null
+++ b/launchd/user_startx/Makefile.am
@@ -0,0 +1,39 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+include $(top_srcdir)/cpprules.in
+
+xinitrcdir = $(XINITDIR)
+
+CPP_FILES_FLAGS = \
+ -DXINITDIR=$(XINITDIR) $(PROGCPPDEFS) -DLIBDIR=$(libdir) \
+ -DSHELL_CMD=$(SHELL_CMD) $(STARTX_COOKIE_FLAGS) \
+ -D__libexecdir__="$(libexecdir)" \
+ -D__bindir__="$(bindir)" \
+ -DLAUNCHD_ID_PREFIX="$(launchdidprefix)"
+
+$(launchdidprefix).startx.plist.cpp: startx.plist.cpp
+ cp $< $@
+
+launchagents_PRE = $(launchdidprefix).startx.plist.cpp
+launchagents_DATA = $(launchagents_PRE:plist.cpp=plist)
+
+EXTRA_DIST = startx.plist.cpp