summaryrefslogtreecommitdiff
path: root/launchd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'launchd/Makefile.am')
-rw-r--r--launchd/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/launchd/Makefile.am b/launchd/Makefile.am
new file mode 100644
index 0000000..6a420e6
--- /dev/null
+++ b/launchd/Makefile.am
@@ -0,0 +1,13 @@
+if APPLE
+libexec_PROGRAMS = x11-exec
+x11_exec_LDFLAGS = -framework CoreServices
+endif
+
+launchagents_PRE = org.x.X11.plist.pre
+launchagents_DATA = $(launchagents_PRE:plist.pre=plist)
+
+CPP_FILES_FLAGS = -D__bindir__="$(bindir)"
+
+CLEANFILES = $(launchagents_DATA)
+
+include $(top_srcdir)/cpprules.in