summaryrefslogtreecommitdiff
path: root/launchd/user_startx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'launchd/user_startx/Makefile.am')
-rw-r--r--launchd/user_startx/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/launchd/user_startx/Makefile.am b/launchd/user_startx/Makefile.am
index bf18fb0..e895ee2 100644
--- a/launchd/user_startx/Makefile.am
+++ b/launchd/user_startx/Makefile.am
@@ -21,9 +21,7 @@
include $(top_srcdir)/cpprules.in
-xinitrcdir = $(XINITDIR)
-
-xinitrc_PROGRAMS = launchd_startx
+libexec_PROGRAMS = launchd_startx
AM_CPPFLAGS = -I$(srcdir)/.. -DXINITDIR=\"$(xinitrcdir)\" -DBINDIR=\"$(bindir)\"
@@ -32,6 +30,7 @@ dist_launchd_startx_SOURCES = \
launchd_startx.c
CPP_FILES_FLAGS = \
+ -D__libexecdir__="$(libexecdir)" \
-D__xinitrcdir__="$(xinitrcdir)" \
-D__bindir__="$(bindir)" \
-DBUNDLE_ID_PREFIX="$(bundleidprefix)"