summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2010-01-15 22:20:56 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2010-01-15 22:20:56 -0800
commit36659aa666808e5b42f5d98bce8f84bf82e88c0e (patch)
tree77f5b2310b0fac843c588ff549bfc5f6d7669064 /Makefile.am
parent6d96dd3d2df7d896a41d770ba380629948ead4d6 (diff)
Integrate gettext support with autotools build system
Mostly cribbed from prior work for libXpm Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c80096d..1063365 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,3 +85,12 @@ ChangeLog:
$(CHANGELOG_CMD)
dist-hook: ChangeLog INSTALL
+
+if USE_GETTEXT
+noinst_DATA = xload.po
+
+xload.po: $(xload_SOURCES:%=$(srcdir)/%)
+ $(AM_V_GEN)xgettext -d xload -n $(xload_SOURCES:%=$(srcdir)/%)
+
+CLEANFILES += xload.po
+endif