summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2010-11-19 22:45:57 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2010-11-19 22:45:57 -0800
commit73941fa2f5e5a71fb36a3b9a9dec8a833898907e (patch)
treeac40b390fea4f78800bcec31cd387956bb6940f5 /Makefile.am
parent6d8da24e45c124162b06529290366d465f1df499 (diff)
Bug 31645 - xlogo: Doesn't build with libXrender and without libXft
https://bugs.freedesktop.org/show_bug.cgi?id=31645 Add AM_CONDITIONAL to skip building RenderLogo.c without Render support Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fa8729e..51bd1dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,11 +27,15 @@ xlogo_SOURCES = \
Logo.c \
Logo.h \
LogoP.h \
- RenderLogo.c \
- RenderLogo.h \
xlogo.c \
xlogo.h
+if USE_RENDER
+xlogo_SOURCES += \
+ RenderLogo.c \
+ RenderLogo.h
+endif
+
appman_PRE = \
xlogo.man