summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-10-15 10:42:54 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-10-15 11:25:32 -0700
commite379927b2d1e24d4c637fe4161dbf3f2fd98e02b (patch)
tree7392eb56e0946efbd39546151889bdb9dd67d9ec /Makefile.am
parente364be848c65d5e286cbc96ccb283b9052fc3c4a (diff)
Use _CONST_X_STRING to make libXt declare String as const char *
Clears 22 out of 36 -Wdiscarded-qualifiers warnings from gcc Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cf9924b..8ccf0ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,6 +21,7 @@
SUBDIRS = man
bin_PROGRAMS = xlogo
+AM_CPPFLAGS = -D_CONST_X_STRING
AM_CFLAGS = $(XLOGO_CFLAGS) $(CWARNFLAGS)
xlogo_LDADD = $(XLOGO_LIBS)