summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-11-19 07:15:37 +0000
committerKevin E Martin <kem@kem.org>2005-11-19 07:15:37 +0000
commitddcaa857470b13840b8a3c3e1748c0154f76b9c2 (patch)
tree2db3425e99e40252b48cb9974cad346c9aaa48a7 /configure.ac
parentf3e7ab0f031b9ff8968596667616e79ec05f9b62 (diff)
Update pkgconfig files to separate library build-time dependencies from
application build-time dependencies, and update package deps to work with separate build roots.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4598e0..5abeac2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,10 @@ if test "x$USE_RENDER" = "xyes" ; then
XLOGO_LIBS="$XLOGO_LIBS $XRENDER_LIBS $XFT_LIBS"
fi
+PKG_CHECK_MODULES(XEXT, xext)
+XLOGO_CFLAGS="$XLOGO_CFLAGS $XEXT_CFLAGS"
+XLOGO_LIBS="$XLOGO_LIBS $XEXT_LIBS"
+
AC_SUBST(XLOGO_CFLAGS)
AC_SUBST(XLOGO_LIBS)