summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:23 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:23 -0500
commite5161d278fcfbf7ec3c4a73b6580993ad563e7ea (patch)
tree429e6a07c8afe0ce2595dcfebadf604ba5227723 /Makefile.am
parent6ca14b864bbbc1b50bdf42806e0f1762a7cf9ca1 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d39e030..acfcc54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,3 +61,13 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog