summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Harris <pharris@opentext.com>2009-10-19 18:21:26 -0700
committerJamey Sharp <jamey@minilop.net>2009-10-19 18:28:33 -0700
commit1839eabbdd697039a264fe7ebb3f4d26f08ddabe (patch)
tree29064dcc066939ce794d606831053e0a0d4d14d2 /configure.ac
parent47f2d188a231a1c59d5d3030a1a2470c774d1e0d (diff)
Rewrite xlsclients to use XCB, avoiding many (many) round trips
This version spends bandwidth to reduce latency; in particular, it aggressively calls query_tree before the answer to get_property(WM_STATE) is available. Even on my local box, this version is 4-10 times faster (30ms typical, vs 200ms typical for Xlib). I get similar results over the local network. At least one person reports this version takes less than 2 seconds over ssh, vs over a minute for the Xlib version (~30x faster). Reviewed-by: Jamey Sharp <jamey@minilop.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1af6ba2..f665380 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,10 +36,14 @@ AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
+# Check for functional strnlen
+AC_USE_SYSTEM_EXTENSIONS
+AC_FUNC_STRNLEN
+
XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XLSCLIENTS, x11 xmuu)
+PKG_CHECK_MODULES(XLSCLIENTS, xcb xcb-atom)
AC_SUBST(XLSCLIENTS_CFLAGS)
AC_SUBST(XLSCLIENTS_LIBS)