summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-02-01 13:53:01 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-02-01 13:53:01 -0800
commit808126e79c99595e42147413898cf4180869cdcd (patch)
tree09f6ef356dde3aabb1d98e8daabb0678ad746e74 /Makefile.am
parentf66e6d2d380457b1f8349eba3621bc3e96359a00 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e36dbb7..8320d74 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,13 @@ xlsfonts_SOURCES = \
appman_PRE = \
xlsfonts.man
-EXTRA_DIST = xlsfonts.sgml
+EXTRA_DIST = xlsfonts.sgml ChangeLog autogen.sh
+MAINTAINERCLEANFILES=ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
appmandir = $(APP_MAN_DIR)