summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:47 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:47 +0000
commit557c649ffb5bbfed8533b3d93ea1dbedaa0fc0ac (patch)
treeb2ee03e7df29de49e09d3b289f88510662591064 /Makefile.am
parenteb77492515f7944b530550950a0143c8fb5b45cf (diff)
Use sed to fill in variables in man page
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a15f5f..b9d5475 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,7 +31,7 @@ xmessage_SOURCES = \
xmessage.c \
xmessage.h
-dist_man1_MANS = \
+appman_SOURCES = \
xmessage.man
# App default files (*.ad)
@@ -54,3 +54,34 @@ EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad) Tests
CLEANFILES = $(APPDEFAULTFILES)
+
+appmandir = $(mandir)/man$(APP_MAN_SUFFIX)
+
+appman_DATA = $(appman_SOURCES:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST += $(appman_SOURCES)
+CLEANFILES += $(appman_DATA)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES += .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@