summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-12 13:07:35 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-12 13:07:35 -0700
commita5044e717eb486ebe79ea109994c3e761df7dc00 (patch)
tree2a0354d872c151889ef772c08beb8f701a908afa /configure.ac
parent817fc3e95863fd2ee8d3861704c1bfdf614a9ac1 (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 5 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 6087c3b..716785e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,26 +27,23 @@ AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
-# Require xorg-macros: XORG_WITH_LINT, XORG_CWARNFLAGS, XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AC_PROG_CC
AC_PROG_INSTALL
-XORG_CWARNFLAGS
+XORG_DEFAULT_OPTIONS
AC_CHECK_HEADERS([wchar.h wctype.h langinfo.h])
# Checks for pkg-config packages
PKG_CHECK_MODULES(XPROP, x11)
-XPROP_CFLAGS="$CWARNFLAGS $XPROP_CFLAGS"
AC_SUBST(XPROP_CFLAGS)
AC_SUBST(XPROP_LIBS)
XORG_WITH_LINT
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
AC_OUTPUT([Makefile])