summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-02-11 10:08:07 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-02-11 10:08:07 -0500
commit4f56a25154eb876f33a46d29eed4be46bba814f2 (patch)
tree7237e346ded86a782734e173f33df7da8fd7fe99 /Makefile.am
parent547b489f70df72524f210cca990d1373cf80eb34 (diff)
config: move CWARNFLAGS from configure.ac to Makefile.am
Compiler warning flags should be explicitly set in the makefile rather than being merged with other packages compiler flags. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1613c4d..3f69bd3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,7 @@ bin_PROGRAMS = xsm
SYSTEM_INIT_DIR = $(libdir)/X11/xsm
-AM_CFLAGS = $(XSM_CFLAGS) -DRSHCMD=\"@RSH@\" \
+AM_CFLAGS = $(XSM_CFLAGS) $(CWARNFLAGS) -DRSHCMD=\"@RSH@\" \
-DSYSTEM_INIT_FILE=\"$(SYSTEM_INIT_DIR)/system.xsm\"
xsm_LDADD = $(XSM_LIBS)