summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:30 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:30 -0500
commit1dee63fcbe0e3915a4b74578d71dab673c6e313d (patch)
tree71f3773f13cb8657824b3616c88278c35cf84701 /Makefile.am
parentadf6777c5c34ca156d77f31af3ab3dec744c109f (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bad4d3b..6f4ca9b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,3 +124,13 @@ SUFFIXES += .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog