summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-01 20:09:07 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-01 20:09:07 +0000
commit2f07c342e877fde5d3f64041ca6ff365a643ddc8 (patch)
treeb4de191a778d1fe52a0a631b39e21a091db3aa8b /Makefile.am
parentb2fec4bfd950c450c774543b3336e1beb0bd9aa1 (diff)
xtrap.pc.in: s/Xfixes/XTrap/ xi.pc.in: s/Xt/Xi/ Xv/src/Makefile.am: remove
whitespace after backslash modularizeapp.sh: s/destkop/desktop/ modular/symlink.sh: Add bitmaps for xeyes, system.xsm for xsm, and Xvidtune.cpp for xvidtune. Also comment out non-existing mga_bios.h Check in buildsystems for xsetroot, xsm, xstdcmap, xtrap, and xvinfo
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am94
1 files changed, 94 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..4f5409f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,94 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xsm
+
+SYSTEM_INIT_DIR = $(libdir)/X11/xsm
+
+
+xsm_CFLAGS = $(DEP_CFLAGS) -DRSHCMD=\"@RSH@\" \
+ -DSYSTEM_INIT_FILE=\"$(SYSTEM_INIT_DIR)/system.xsm\"
+
+xsm_LDADD = $(DEP_LIBS)
+
+xsm_SOURCES = \
+ auth.c \
+ auth.h \
+ choose.c \
+ choose.h \
+ info.c \
+ info.h \
+ list.c \
+ list.h \
+ lock.c \
+ lock.h \
+ log.c \
+ log.h \
+ mainwin.c \
+ mainwin.h \
+ misc.c \
+ popup.c \
+ popup.h \
+ printhex.c \
+ prop.c \
+ prop.h \
+ remote.c \
+ restart.c \
+ restart.h \
+ save.c \
+ save.h \
+ saveutil.c \
+ saveutil.h \
+ signals.c \
+ xsm.c \
+ xsm.h \
+ xtwatch.c \
+ xtwatch.h
+
+dist_man_MANS = \
+ xsm.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+
+APPDEFAULTFILES = \
+ XSm
+
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+# system init file
+
+systeminitdir = $(SYSTEM_INIT_DIR)
+
+systeminit_DATA = system.xsm
+
+#
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad) globals.c system.xsm
+
+CLEANFILES = $(APPDEFAULTFILES)
+