summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-01 20:09:07 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-01 20:09:07 +0000
commit2f07c342e877fde5d3f64041ca6ff365a643ddc8 (patch)
treeb4de191a778d1fe52a0a631b39e21a091db3aa8b /configure.ac
parentb2fec4bfd950c450c774543b3336e1beb0bd9aa1 (diff)
xtrap.pc.in: s/Xfixes/XTrap/ xi.pc.in: s/Xt/Xi/ Xv/src/Makefile.am: remove
whitespace after backslash modularizeapp.sh: s/destkop/desktop/ modular/symlink.sh: Add bitmaps for xeyes, system.xsm for xsm, and Xvidtune.cpp for xvidtune. Also comment out non-existing mga_bios.h Check in buildsystems for xsetroot, xsm, xstdcmap, xtrap, and xvinfo
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac66
1 files changed, 66 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..d9ba5c2
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,66 @@
+
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(xsm,[7.0], [xorg@freedesktop.org],xsm)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+RSH=
+if [[ -z $RSH ]] ; then
+ AC_PATH_PROG(RSH,rsh)
+fi
+if [[ -z $RSH ]] ; then
+ AC_PATH_PROG(RSH,rcmd)
+fi
+if [[ -z $RSH ]] ; then
+ AC_PATH_PROG(RSH,remsh)
+fi
+if [[ -z $RSH ]] ; then
+ AC_MSG_ERROR(No rsh like program found)
+fi
+
+#if !defined(RshCmd)
+#if SystemV
+#ifdef HPArchitecture
+#define RshCmd remsh
+#else
+#define RshCmd rcmd
+#endif
+#else
+#define RshCmd rsh
+#endif
+#endif
+
+# Checks for pkg-config packages
+XAW_CHECK_XPRINT_SUPPORT(DEP)
+
+AC_SUBST(DEP_CFLAGS)
+AC_SUBST(DEP_LIBS)
+
+AC_OUTPUT([Makefile])