summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2021-11-28 11:02:18 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2021-11-30 17:52:59 +0000
commit107fbd198f2d4cec9efb54e89a568a595ac2d1e3 (patch)
treee02cfd400aef328e6ff8a6a63fc50c73e7603fe3 /configure.ac
parent416a3fc806f47b158b489bb44f7709fc44fa4f3e (diff)
Add noreturn attributes suggested by gcc
misc.c: In function ‘nomem’: misc.c:106:1: warning: function might be candidate for attribute ‘noreturn’ [-Wsuggest-attribute=noreturn] 106 | nomem(void) | ^~~~~ xsm.c:657:1: warning: function might be candidate for attribute ‘noreturn’ [-Wsuggest-attribute=noreturn] 657 | EndSession(int status) | ^~~~~~~~~~ Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a2195a8..192b7b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,7 +47,7 @@ AC_SUBST(RSH)
AC_CHECK_FUNCS([mkstemp putenv])
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XSM, [x11 xt > 1.0.99 ice sm xaw7])
+PKG_CHECK_MODULES(XSM, [x11 xt > 1.0.99 ice sm xaw7 xproto >= 7.0.17])
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
AC_ARG_WITH(appdefaultdir,