summaryrefslogtreecommitdiff
path: root/masterdb/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-09-05 15:35:55 -0400
committerGaetan Nadon <memsize@videotron.ca>2011-09-09 14:15:24 -0400
commit93f58fd482c58f669e37df1e415cfde06324b548 (patch)
tree36099d13b03a4499773318bf5b7652610b2f7439 /masterdb/Makefile.am
parent2d3a9c663c99958de27827668fd63608b25433de (diff)
masterdb: add olink support for chunked html
For olinks to chunked html, the masterdb cannot contain the baseuri attribute. The xsl parameter olink.base.uri needs to be used in makefiles for non chunked html while the chunked html does not use it. The txt and ps documents cannot be an end point of olinks, so no target dbs will be generated for those formats, hence no masterdb needed either. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'masterdb/Makefile.am')
-rw-r--r--masterdb/Makefile.am20
1 files changed, 4 insertions, 16 deletions
diff --git a/masterdb/Makefile.am b/masterdb/Makefile.am
index 4b8044d..fd571b0 100644
--- a/masterdb/Makefile.am
+++ b/masterdb/Makefile.am
@@ -2,29 +2,17 @@
master_PRE = masterdb.xml
sgmldbs_DATA = \
$(master_PRE:xml=html.xml) \
- $(master_PRE:xml=pdf.xml) \
- $(master_PRE:xml=ps.xml) \
- $(master_PRE:xml=txt.xml)
+ $(master_PRE:xml=pdf.xml)
EXTRA_DIST = $(master_PRE)
CLEANFILES = $(sgmldbs_DATA)
%.html.xml: %.xml
- $(AM_V_GEN)$(SED) -e 's|__ext__|html|g' \
- -e 's|__db__|html|g' \
- -e 's|@datarootdir[@]|$(datarootdir)|g' < $< > $@
-
-%.txt.xml: %.xml
- $(AM_V_GEN)$(SED) -e 's|__ext__|txt|g' \
+ $(AM_V_GEN)$(SED) \
-e 's|__db__|html|g' \
-e 's|@datarootdir[@]|$(datarootdir)|g' < $< > $@
%.pdf.xml: %.xml
- $(AM_V_GEN)$(SED) -e 's|__ext__|pdf|g' \
- -e 's|__db__|fo|g' \
- -e 's|@datarootdir[@]|$(datarootdir)|g' < $< > $@
-
-%.ps.xml: %.xml
- $(AM_V_GEN)$(SED) -e 's|__ext__|ps|g' \
- -e 's|__db__|fo|g' \
+ $(AM_V_GEN)$(SED) \
+ -e 's|__db__|pdf|g' \
-e 's|@datarootdir[@]|$(datarootdir)|g' < $< > $@