summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2015-09-18 00:27:13 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2015-09-18 00:29:20 +1000
commit80c356f58fed47080eb6fa5756a122dbe14e5f6f (patch)
treedd982698b3f61eb707f5773ef338fc7906c70f24 /configure.ac
parent1645a79c343ea3cf8bbd71a36e9106b22e541c71 (diff)
conf: install the libinput xorg.conf.d snippet
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bfb1d75..f42fee3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,13 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
+AC_ARG_WITH(xorg-conf-dir,
+ AC_HELP_STRING([--with-xorg-conf-dir=DIR],
+ [Default xorg.conf.d directory [[default=$prefix/share/X11/xorg.conf.d/]]]),
+ [xorgconfdir="$withval"],
+ [xorgconfdir="$prefix/share/X11/xorg.conf.d"])
+AC_SUBST(xorgconfdir)
+
# X Server SDK location is required to install header files
sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`