summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2016-09-16 17:26:06 +0900
committerPeter Hutterer <peter.hutterer@who-t.net>2016-09-21 16:29:01 +1000
commit0cfe9ec6c23e73507fd0797bae24c5ed6fcce033 (patch)
tree2dd135f0d68ccc1e6a2575c5d02e2d840dfc6a74 /configure.ac
parentb87d2530db46a08de15376722873295e01bef16f (diff)
Fix --with-xorg-conf-dir default value
If --prefix isn't specified on the command line, $prefix contains "NONE" at this point, not the default prefix value. So make install would attempt to install the xorg.conf.d snippet to ${DESTDIR}NONE/share/X11/xorg.conf.d/. Avoid this by leaving ${prefix} verbatim in the default value, to be resolved by make. Signed-off-by: Michel Dänzer <michel.daenzer@amd.com> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4c72c75..4158e57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,9 +58,9 @@ AC_SUBST(inputdir)
AC_ARG_WITH(xorg-conf-dir,
AC_HELP_STRING([--with-xorg-conf-dir=DIR],
- [Default xorg.conf.d directory [[default=$prefix/share/X11/xorg.conf.d/]]]),
+ [Default xorg.conf.d directory [[default=${prefix}/share/X11/xorg.conf.d]]]),
[xorgconfdir="$withval"],
- [xorgconfdir="$prefix/share/X11/xorg.conf.d"])
+ [xorgconfdir='${prefix}/share/X11/xorg.conf.d'])
AC_SUBST(xorgconfdir)
# X Server SDK location is required to install header files