summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gmail.com>2011-05-14 03:14:56 +0200
committerChristoph Brill <egore911@egore911.de>2011-05-15 21:46:06 +0200
commit39afe69ad7d2258d4043044d1283bd6e311e48da (patch)
tree0ebd3e7a95dbbc86ac8bbddd070d46759f230d2d /Makefile.am
parent4005df66072ceac175ea71427deb16176262f197 (diff)
build: collapse all Makefile.am files into a single non-recursive one.
With this change, the whole of the build is done non-recursively in the top-level Makefile.am. This reduces the amount of overhead due to recursing into directories only to build one file. Signed-off-by: Diego Elio Pettenò <flameeyes@gmail.com> Signed-off-by: Christoph Brill <egore911@egore911.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am95
1 files changed, 93 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index edd28a6..7cedc61 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,13 +18,104 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-SUBDIRS = include src man tools conf test
MAINTAINERCLEANFILES = ChangeLog INSTALL
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xorg-synaptics.pc
-.PHONY: ChangeLog INSTALL
+sdk_HEADERS = include/synaptics.h include/synaptics-properties.h
+
+input_LTLIBRARIES = @DRIVER_NAME@_drv.la
+
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# -shared avoid building the static archive
+@DRIVER_NAME@_drv_la_LDFLAGS = -module -avoid-version -shared
+@DRIVER_NAME@_drv_la_CPPFLAGS = -I$(top_srcdir)/include
+@DRIVER_NAME@_drv_la_CFLAGS = $(XORG_CFLAGS)
+
+@DRIVER_NAME@_drv_la_SOURCES = src/@DRIVER_NAME@.c src/synapticsstr.h \
+ src/synproto.h \
+ src/properties.c
+
+if BUILD_PS2COMM
+@DRIVER_NAME@_drv_la_SOURCES += \
+ src/alpscomm.c \
+ src/ps2comm.c src/ps2comm.h
+endif
+
+if BUILD_EVENTCOMM
+@DRIVER_NAME@_drv_la_SOURCES += \
+ src/eventcomm.c src/eventcomm.h
+endif
+
+if BUILD_PSMCOMM
+@DRIVER_NAME@_drv_la_SOURCES += \
+ src/psmcomm.c
+endif
+
+bin_PROGRAMS = synclient syndaemon
+
+synclient_SOURCES = tools/synclient.c
+synclient_CFLAGS = -I$(top_srcdir)/include $(XORG_CFLAGS) $(XI_CFLAGS)
+synclient_LDADD = $(XI_LIBS)
+
+syndaemon_SOURCES = tools/syndaemon.c
+syndaemon_CFLAGS = -I$(top_srcdir)/include $(XORG_CFLAGS) $(XI_CFLAGS) $(XTST_CFLAGS)
+syndaemon_LDADD = $(XI_LIBS) $(XTST_LIBS)
+
+if HAS_XORG_CONF_DIR
+dist_config_DATA = conf/50-synaptics.conf
+else
+fdidir = $(datadir)/hal/fdi/policy/20thirdparty
+dist_fdi_DATA = conf/11-x11-synaptics.fdi
+endif
+
+if ENABLE_UNIT_TESTS
+if BUILD_EVENTCOMM
+check_PROGRAMS = eventcomm-test
+
+eventcomm_test_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/include
+eventcomm_test_CFLAGS = $(XORG_CFLAGS) $(CWARNFLAGS)
+eventcomm_test_SOURCES = test/eventcomm-test.c\
+ src/eventcomm.c \
+ test/fake-symbols.c test/fake-symbols.h
+
+TESTS = $(check_PROGRAMS)
+endif
+endif
+
+synclientmandir = $(APP_MAN_DIR)
+synclientman_PRE = man/synclient.man
+synclientman_DATA = $(synclientman_PRE:man=@APP_MAN_SUFFIX@)
+
+syndaemonmandir = $(APP_MAN_DIR)
+syndaemonman_PRE = man/syndaemon.man
+syndaemonman_DATA = $(syndaemonman_PRE:man=@APP_MAN_SUFFIX@)
+
+drivermandir = $(DRIVER_MAN_DIR)
+driverman_PRE = man/@DRIVER_NAME@.man
+driverman_DATA = $(driverman_PRE:man=@DRIVER_MAN_SUFFIX@)
+
+EXTRA_DIST = man/@DRIVER_NAME@.man man/synclient.man man/syndaemon.man
+
+CLEANFILES = $(driverman_DATA) $(synclientman_DATA) $(syndaemonman_DATA)
+
+SUFFIXES = .$(DRIVER_MAN_SUFFIX) .man
+
+.PHONY: ChangeLog INSTALL mandir
+
+mandir:
+ $(MKDIR_P) man
+
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+.man.$(DRIVER_MAN_SUFFIX):
+ @$(MKDIR_P) man
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
+
+.man.$(APP_MAN_SUFFIX):
+ @$(MKDIR_P) man
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
INSTALL:
$(INSTALL_CMD)