summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2011-03-18 20:34:38 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2011-04-04 09:39:19 +1000
commit9290ce357b5063e8170f28282711718794a3c2d0 (patch)
treee5c81fb054d4bd1a240f476adaa452bbff0e2ae1 /Makefile.am
parentbc89d7db428dbf38a9f0f9b5f5e8efd1afae71f1 (diff)
Add basic framework for unit-testing.
Also adds a bunch of fake symbols so we can link. Note that any of these symbols will return false, 0 or whatever the zero value for the symbol is. Care must be taken when writing test that this doesn't screw up the test. Tests are always built but only run on make check. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 538bbc5..edd28a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,7 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-SUBDIRS = include src man tools conf
+SUBDIRS = include src man tools conf test
MAINTAINERCLEANFILES = ChangeLog INSTALL
pkgconfigdir = $(libdir)/pkgconfig