summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Brill <egore911@egore911.de>2008-07-14 20:43:55 +0200
committerChristoph Brill <egore911@egore911.de>2008-07-14 20:43:55 +0200
commit2cdb4bb00b3e643abe24da83a006629435fb5c5e (patch)
tree17b3f10cabcdc96199f999deb66fa9d2c60a45f2 /configure.ac
parent63d2a8ce5b34c1d98798d44842b362c4ff77d526 (diff)
Build psmcomm on *BSD systems only.
This is the second part of fixing the backend part of synaptics. The new build system is now able to detect whether it's running on *BSD or on Linux and will only build the backends that are available on these platforms. Also it will remove any reference from the built driver to the non-available backends. Thanks to Christian Schmitt for reporting.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ad45502..a12c64e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,19 +44,32 @@ AC_PROG_CC
AH_TOP([#include "xorg-server.h"])
-AC_MSG_CHECKING([if eventcomm will be built])
+AC_MSG_CHECKING([which optional backends will be build])
case "${host}" in
*linux*)
- AC_MSG_RESULT([yes])
+ AC_MSG_RESULT([eventcomm])
BUILD_EVENTCOMM="yes"
+ BUILD_PSMCOMM="no"
+ ;;
+*freebsd*)
+ AC_MSG_RESULT([psmcomm])
+ BUILD_EVENTCOMM="no"
+ BUILD_PSMCOMM="yes"
;;
*)
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([none])
BUILD_EVENTCOMM="no"
+ BUILD_PSMCOMM="no"
;;
esac
AM_CONDITIONAL([BUILD_EVENTCOMM], [test "x${BUILD_EVENTCOMM}" = "xyes"])
-
+if test "x${BUILD_EVENTCOMM}" = "xyes" ; then
+ AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
+fi
+AM_CONDITIONAL([BUILD_PSMCOMM], [test "x$BUILD_PSMCOMM}" = "xyes"])
+if test "x${BUILD_PSMCOMM}" = "xyes" ; then
+ AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])
+fi
#AC_DEFINE(XFree86LOADER,1,[Stub define for loadable drivers])
#