summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndre Herms <aherms(ae)ivs(d)cs(d)uni-magdeburg(d)de>2008-10-09 21:59:48 +0200
committerChristoph Brill <egore911@egore911.de>2008-10-16 21:02:52 +0200
commit641b26da531b38313ecc68badac1a3ccfd6fc7af (patch)
treeb696e5bade68a9ec70c2a25f4e2f2a5abdaef687 /configure.ac
parente7f6131b56f4785fc57f19e9feefe1e934425742 (diff)
[syndaemon] use Xrecord extension in syndaemon to avoid polling.
This patch prevents the polling of the keyboard state. Instead it uses the XRecord extension of the Xserver for an event triggered notification of key events. Of course, there is a fallback to the polling when no XRecord extension is found. This should finally stop complains of syndaemon preventing good power saving. Signed-off-by: Christoph Brill <egore911@egore911.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 14 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 69f1041..23c9f26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,9 +22,9 @@
AC_PREREQ(2.57)
AC_INIT([xf86-input-synaptics],
- 0.15.2,
- [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
- xf86-input-synaptics)
+ 0.15.2,
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
+ xf86-input-synaptics)
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_AUX_DIR(.)
@@ -90,10 +90,10 @@ fi
#fi
AC_ARG_WITH(xorg-module-dir,
- AC_HELP_STRING([--with-xorg-module-dir=DIR],
- [Default xorg module directory [[default=$libdir/xorg/modules]]]),
- [moduledir="$withval"],
- [moduledir="$libdir/xorg/modules"])
+ AC_HELP_STRING([--with-xorg-module-dir=DIR],
+ [Default xorg module directory [[default=$libdir/xorg/modules]]]),
+ [moduledir="$withval"],
+ [moduledir="$libdir/xorg/modules"])
inputdir=${moduledir}/input
AC_SUBST(inputdir)
@@ -111,6 +111,7 @@ AC_SUBST([CFLAGS])
# Checks for libraries.
PKG_CHECK_MODULES(XLIB, x11) # needed for syndaemon
+PKG_CHECK_MODULES(XRECORD, xtst, AC_DEFINE([HAVE_XRECORD],[],[Use XRecord]), true)
# Checks for header files.
AC_HEADER_STDC
@@ -119,9 +120,9 @@ XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
AC_OUTPUT([Makefile
- src/Makefile
- man/Makefile
- tools/Makefile
- fdi/Makefile
- include/Makefile
- xorg-synaptics.pc])
+ src/Makefile
+ man/Makefile
+ tools/Makefile
+ fdi/Makefile
+ include/Makefile
+ xorg-synaptics.pc])