summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2010-04-08 14:47:08 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2010-04-16 10:34:01 +1000
commit87b29e6004a9a7f744eb6e9c2bf9539579ecefbf (patch)
treeb490dce18d918fea1c2d65d5eebc30382f26a7c4 /configure.ac
parente22a850e69d670152371644fc4e63976f484d7b5 (diff)
Add 50-synaptics.conf snippet.
If the server exports the sysconfigdir variable, install the 50-synaptics.conf snippet in the directory provided. This patch also moves the fdi file from fdi/ into the new conf/ subdir to have a single location for all config files. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Dan Nicholson <dbn.lists@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 82500e9..53e1320 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,6 +139,14 @@ fi
AM_CONDITIONAL(BUILD_TOOLS, [ test "$BUILD_TOOLS" = "yes" ])
AC_SUBST(BUILD_TOOLS)
+AC_ARG_WITH(xorg-conf-dir,
+ AC_HELP_STRING([--with-xorg-conf-dir=DIR],
+ [Default xorg.conf.d directory [[default=from $PKG_CONFIG xorg-server]]]),
+ [XORG_CONF_DIR="$withval"],
+ [XORG_CONF_DIR="`$PKG_CONFIG --variable=sysconfigdir xorg-server`"])
+AC_SUBST(XORG_CONF_DIR)
+AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$XORG_CONF_DIR" != "x" && test "x$XORG_CONF_DIR" != "xno"])
+
# Checks for header files.
AC_HEADER_STDC
@@ -146,6 +154,6 @@ AC_OUTPUT([Makefile
src/Makefile
man/Makefile
tools/Makefile
- fdi/Makefile
+ conf/Makefile
include/Makefile
xorg-synaptics.pc])