summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2011-03-18 20:34:38 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2011-04-04 09:39:19 +1000
commit9290ce357b5063e8170f28282711718794a3c2d0 (patch)
treee5c81fb054d4bd1a240f476adaa452bbff0e2ae1 /configure.ac
parentbc89d7db428dbf38a9f0f9b5f5e8efd1afae71f1 (diff)
Add basic framework for unit-testing.
Also adds a bunch of fake symbols so we can link. Note that any of these symbols will return false, 0 or whatever the zero value for the symbol is. Care must be taken when writing test that this doesn't screw up the test. Tests are always built but only run on make check. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a7ba59..cda82fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,7 @@ m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.13 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.13)
XORG_DEFAULT_OPTIONS
+XORG_ENABLE_UNIT_TESTS
# Checks for libraries.
AC_CHECK_LIB([m], [rint])
@@ -149,6 +150,7 @@ AC_CONFIG_FILES([Makefile
tools/Makefile
conf/Makefile
include/Makefile
+ test/Makefile
xorg-synaptics.pc])
AC_OUTPUT