summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-11-02 10:06:01 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-11-05 08:51:46 +1000
commitd3c1b80692013abb2f2dea6ec7acf1d8a89a18d2 (patch)
treea26d54a4bab598e37d73181d53d1dc79e2027659 /configure.ac
parent0198c02774a5063c5cf45b6eddef4a33d9f494d7 (diff)
Clean up debugging system, allow for --enable-debug
Add --enable-debug to list of configure options. Clean up the DBG macro to use xf86MsgVerb and supply the verbosity. Don't use ErrorF from the driver, use xf86Msg instead. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Acked-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdc7764..49383cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,15 @@ if test "x${BUILD_PSMCOMM}" = "xyes" ; then
AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])
fi
+AC_ARG_ENABLE(debug, AS_HELP_STRING([--enable-debug],
+ [Enable debugging (default: disabled)]),
+ [DEBUGGING=$enableval], [DEBUGGING=no])
+
+if test "x$DEBUGGING" = xyes; then
+ AC_DEFINE(DEBUG, 1, [Enable debugging code])
+fi
+AM_CONDITIONAL(DEBUG, [test "x$DEBUGGING" = xyes])
+
AC_ARG_WITH(xorg-module-dir,
AC_HELP_STRING([--with-xorg-module-dir=DIR],
[Default xorg module directory [[default=$libdir/xorg/modules]]]),