summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-05-25 13:00:04 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-05-31 12:53:27 -0400
commit2554d5b615101011c09c4786b8a18216ec0909e2 (patch)
treee6d1cdbc8187c363cfaa1b5b4b8962da3f931207 /configure.ac
parenta101621bf624466f66da41a8fa6b5ba796cd10fd (diff)
config: unconditionaly build synclient and syndaemon apps
The current conditional building of the apps was introduced by commit 080caee95c46bb471d1442dcab246460cad8c7be due to optional support properties. This is no longer an issue. There are no longer any reason not to build these bona fide apps. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 13 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 69c6ff4..f235802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,12 +90,6 @@ if test "x$DEBUGGING" = xyes; then
fi
AM_CONDITIONAL(DEBUG, [test "x$DEBUGGING" = xyes])
-# Define a configure option to disable building synclient and syndaemon
-AC_ARG_ENABLE([tools],
- AS_HELP_STRING([--enable-tools], [Build synclient and syndaemon [[default=auto]]]),
- [build_tools="$enableval"],
- [build_tools="auto"])
-
# -----------------------------------------------------------------------------
# Determine which backend, if any, to build
# -----------------------------------------------------------------------------
@@ -121,30 +115,20 @@ AM_CONDITIONAL([BUILD_PSMCOMM], [test "x${BUILD_PSMCOMM}" = "xyes"])
# -----------------------------------------------------------------------------
# Dependencies for synclient and syndaemon
# -----------------------------------------------------------------------------
-# If the tools dependencies are satisfied, look for XRecord impl and record.h headers
-PKG_CHECK_MODULES(XI, x11 inputproto [xi >= 1.2], have_depends="yes", have_depends="no")
-if test "x$have_depends" = "xyes"; then
- if test "x$build_tools" != "xno"; then
- # The syndaemon program uses an optional XRecord extension implementation
- # If libxtst >= 1.0.99 is installed, Cflags contains the path to record.h
- # If recordproto < 1.13.99.1 is installed, Cflags contains the path to record.h
- PKG_CHECK_MODULES(XTST, xtst recordproto, have_libxtst="yes", have_libxtst="no")
- if test "x$have_libxtst" = "xyes" ; then
- # Header record.h may come from the xtst or recordproto package, or may be missing
- SAVE_CPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS $XTST_CFLAGS"
- AC_CHECK_HEADERS([X11/extensions/record.h],,,[#include <X11/Xlib.h>])
- CPPFLAGS="$SAVE_CPPFLAGS"
- fi
- fi
-else
- if test "x$build_tools" = "xyes"; then
- AC_MSG_ERROR([Dependencies failed for synclient and syndaemon.])
- else
- AC_MSG_WARN([Not building synclient and syndaemon.])
- fi
+# Obtain compiler/linker options for the Synaptics apps dependencies
+PKG_CHECK_MODULES(XI, x11 inputproto [xi >= 1.2])
+
+# The syndaemon program uses an optional XRecord extension implementation
+# If libxtst >= 1.0.99 is installed, Cflags contains the path to record.h
+# If recordproto < 1.13.99.1 is installed, Cflags contains the path to record.h
+PKG_CHECK_MODULES(XTST, xtst recordproto, have_libxtst="yes", have_libxtst="no")
+if test "x$have_libxtst" = "xyes" ; then
+ # Header record.h may come from the xtst or recordproto package, or may be missing
+ SAVE_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $XTST_CFLAGS"
+ AC_CHECK_HEADERS([X11/extensions/record.h],,,[#include <X11/Xlib.h>])
+ CPPFLAGS="$SAVE_CPPFLAGS"
fi
-AM_CONDITIONAL(BUILD_TOOLS, [test "x$have_depends" = xyes && test "x$build_tools" != xno])
# -----------------------------------------------------------------------------
AC_CONFIG_FILES([Makefile