summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-10-06 08:06:37 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-10-08 10:57:58 +1000
commit807a0ecd61ba5fcde57f5e218c790edd58784a56 (patch)
tree4b6c47aea30d39354b95ab2d58c98eef0dfafbe4 /configure.ac
parent4422003fafe811a2d2e2fca818dc58f706e67918 (diff)
Require recordproto 1.13 or libXtst 1.1 for record support.
The record.h header used to be in recordproto up to excluding 1.14, then moved to libXtst. Check for both and enable it dependent on which version we have. This avoids build errors on setups where a user updated recordproto but not libXtst. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Xavier Chantry <shiningxc@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e9e0560..44800ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,7 +106,14 @@ AC_ARG_ENABLE(tools,
[build_tools="auto"])
if test "x$build_tools" != "xno"; then
- PKG_CHECK_MODULES(XRECORD, xtst, AC_DEFINE([HAVE_XRECORD],[],[Use XRecord]), true)
+ # Record.h is either in recordproto up to 1.13.2 or in libXtst 1.1.
+ PKG_CHECK_MODULES(XTST_1_1, [xtst >= 1.0.99.1], HAVE_LIBXTST="yes", HAVE_LIBXTST="no")
+ PKG_CHECK_MODULES(RECORDPROTO_1_13, xtst [recordproto < 1.13.99.1], HAVE_RECORDPROTO="yes", HAVE_RECORDPROTO="no")
+
+ if test "x$HAVE_LIBXTST" = "xyes" || test "x$HAVE_RECORDPROTO" = "xyes" ; then
+ AC_DEFINE([HAVE_XRECORD],[],[Use XRecord])
+ fi
+
PKG_CHECK_MODULES(XI, x11 [xi >= 1.2] [xorg-server >= 1.6],
BUILD_TOOLS="yes"; AC_DEFINE(BUILD_TOOLS, 1, "Build synclient and syndaemon"),
BUILD_TOOLS="no";