summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-03-18 18:38:12 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-03-23 16:45:48 +1000
commita07a840b26827e1a2c8cccd255177b693c5b91e8 (patch)
tree88fc4aa8dcab3f2c60837fd05437ddd3e857c68e /configure.ac
parentea7695037070e7037a4b20db87dd466c643ac088 (diff)
Don't fail when building against server 1.5
The driver had all the right guards, but synclient and syndaemon didn't. Check for xserver 1.6 and higher and disable property support in synclient and syndaemon. Note that the property headers still get installed even without support for properties in the driver. This ensures that apps looking for synaptics >= thisversion don't fail miserably. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Signed-off-by: Henrik Rydberg <rydberg@euromail.se> Signed-off-by: Christoph Brill <egore@gmx.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6da52c0..4280fff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,13 @@ PKG_CHECK_MODULES(XORG, xorg-server xproto $REQUIRED_MODULES)
sdkdir=$(pkg-config --variable=sdkdir xorg-server)
AC_SUBST([sdkdir])
+PKG_CHECK_MODULES(XORG16, [xorg-server >= 1.6],
+ HAVE_PROPERTIES="yes"; AC_DEFINE(HAVE_PROPERTIES, 1,
+ "Input Device Property support"),
+ HAVE_PROPERTIES="no");
+AM_CONDITIONAL(HAVE_PROPERTIES, [ test "$HAVE_PROPERTIES" = "yes" ])
+AC_SUBST(HAVE_PROPERTIES)
+
CFLAGS="$CFLAGS $XORG_CFLAGS "' -I$(top_srcdir)/src'
AC_SUBST([CFLAGS])