summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2014-05-15 08:34:55 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2014-08-08 11:09:01 +1000
commita36edf8307ab9b5bffca103dd875623a66012c0b (patch)
tree9c383f0d82bfebcf3b2c30ae730b64a0e467a2aa /configure.ac
parentc1457c0f71e30c194180164320759849fa09bf9b (diff)
Use libevdev's per-device logging functions instead of the global handler
Per-device logging functions don't interfere with other drivers if they also use libevdev, so use those instead the global log handler if available. If not available, drop libevdev logging, I don't want to maintain the ifdef mess and the logging doesn't give us _that_ much benefit. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b3a726..0a2bfb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,13 @@ esac
if test "x$BUILD_EVENTCOMM" = xyes; then
AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
PKG_CHECK_MODULES(LIBEVDEV, [libevdev >= 0.4])
+ SAVE_LIBS="$LIBS"
+ LIBS="$LIBEVDEV_LIBS"
+ AC_CHECK_LIB(evdev, libevdev_set_device_log_function,
+ [AC_DEFINE(HAVE_LIBEVDEV_DEVICE_LOG_FUNCS, 1,
+ [libevdev supports per-device log functions])],
+ [])
+ LIBS="$SAVE_LIBS"
fi
if test "x$BUILD_PSMCOMM" = xyes; then
AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])