summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-05-24 15:27:56 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-05-31 12:53:17 -0400
commite4d280dfbdb2d1a916e6ad9a4cdc3f22f2c37d57 (patch)
tree0c4afba81ecad589a6f0b9372e63c4869bbf41e0 /configure.ac
parentf3e4c586037a5785f786ff74c89c87de7d4ac344 (diff)
config: close a loophole where user input means x server has a feature
If a user provides a path in --with-xorg-conf-dir, the configuartion assumes the server does have a config path which may not be the case. Resolve this by testing the value of the server returned sysconfigdir rather than the user provided value. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5d6af1d..5c386b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,14 +71,15 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
-# Define a configure option for an alternate configuration directory
+# Define a configure option for an alternate X Server configuration directory
+sysconfigdir=`$PKG_CONFIG --variable=sysconfigdir xorg-server`
AC_ARG_WITH(xorg-conf-dir,
AC_HELP_STRING([--with-xorg-conf-dir=DIR],
[Default xorg.conf.d directory [[default=from $PKG_CONFIG xorg-server]]]),
[XORG_CONF_DIR="$withval"],
- [XORG_CONF_DIR="`$PKG_CONFIG --variable=sysconfigdir xorg-server`"])
+ [XORG_CONF_DIR="$sysconfigdir"])
AC_SUBST(XORG_CONF_DIR)
-AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$XORG_CONF_DIR" != "x" && test "x$XORG_CONF_DIR" != "xno"])
+AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$sysconfigdir" != "x"])
# Define a configure option to enable code debugging
AC_ARG_ENABLE(debug, AS_HELP_STRING([--enable-debug],