summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2010-01-08 16:22:50 +0000
committerPeter Hutterer <peter.hutterer@who-t.net>2010-01-11 10:18:03 +1000
commita1776829076a6774571fa82ea4adde03c3c6c5b4 (patch)
tree4f41567145f29af93058f9099be66137c585fcb8 /configure.ac
parent94aaded93d035b0a65b4f7a80f9bdf6cf1ae2d66 (diff)
synaptics: don't link the tools against `pkg-config --libs xorg-server`
Separate the checks for xserver 1.6 and for libXi in configure, so we can link the tools against libXi but not pixman and pciaccess. Signed-off-by: Julien Cristau <jcristau@debian.org> Reviewed-by: Dan Nicholson <dbn.lists@gmail.com> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 15 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 4e63006..4483890 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,15 +123,21 @@ if test "x$build_tools" != "xno"; then
AC_DEFINE([HAVE_XRECORD],[],[Use XRecord])
fi
- PKG_CHECK_MODULES(XI, x11 [xi >= 1.2] [xorg-server >= 1.6],
- BUILD_TOOLS="yes"; AC_DEFINE(BUILD_TOOLS, 1, "Build synclient and syndaemon"),
- BUILD_TOOLS="no";
- if test "x$build_tools" = "xyes"; then
- AC_MSG_ERROR([Dependencies failed for synclient and syndaemon.])
- else
- AC_MSG_WARN([Not building synclient and syndaemon.])
- fi
- )
+ if test "x$HAVE_PROPERTIES" = "xyes"; then
+ PKG_CHECK_MODULES(XI, x11 [xi >= 1.2],
+ BUILD_TOOLS="yes"; AC_DEFINE(BUILD_TOOLS, 1, "Build synclient and syndaemon"),
+ BUILD_TOOLS="no")
+ else
+ BUILD_TOOLS="no"
+ fi
+
+ if test "x$BUILD_TOOLS" = "xno"; then
+ if test "x$build_tools" = "xyes"; then
+ AC_MSG_ERROR([Dependencies failed for synclient and syndaemon.])
+ else
+ AC_MSG_WARN([Not building synclient and syndaemon.])
+ fi
+ fi
fi
AM_CONDITIONAL(BUILD_TOOLS, [ test "$BUILD_TOOLS" = "yes" ])
AC_SUBST(BUILD_TOOLS)