summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorChristoph Brill <egore911@egore911.de>2008-07-11 19:29:58 +0200
committerChristoph Brill <egore911@egore911.de>2008-07-11 19:34:14 +0200
commita2e1f9e0a22ed0d9e7728f77978bbdace712dcae (patch)
tree41b50c0d6babbcfe2696fcd27fec6dd98a31a748 /man/Makefile.am
parent52e395218afa01d52be8f351bd846bd0460a79cb (diff)
Build the manpages for the synclient and syndaemon
This uses the facilities to build the drivers man page to also build the two configuration programs.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index bf7ec17..8a58c1f 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -25,15 +25,21 @@
# from the copyright holders.
#
-drivermandir = $(DRIVER_MAN_DIR)
+synclientmandir = $(APP_MAN_DIR)
+synclientman_PRE = synclient.man
+synclientman_DATA = $(synclientman_PRE:man=@APP_MAN_SUFFIX@)
-driverman_PRE = @DRIVER_NAME@.man
+syndaemonmandir = $(APP_MAN_DIR)
+syndaemonman_PRE = syndaemon.man
+syndaemonman_DATA =$(syndaemonman_PRE:man=@APP_MAN_SUFFIX@)
+drivermandir = $(DRIVER_MAN_DIR)
+driverman_PRE = @DRIVER_NAME@.man
driverman_DATA = $(driverman_PRE:man=@DRIVER_MAN_SUFFIX@)
-EXTRA_DIST = @DRIVER_NAME@.man
+EXTRA_DIST = @DRIVER_NAME@.man synclient.man syndaemon.man
-CLEANFILES = $(driverman_DATA)
+CLEANFILES = $(driverman_DATA) $(synclientman_DATA) $(syndaemonman_DATA)
SED = sed
@@ -57,3 +63,6 @@ SUFFIXES = .$(DRIVER_MAN_SUFFIX) .man
.man.$(DRIVER_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@
+