summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristoph Brill <egore911@egore911.de>2008-07-14 20:43:55 +0200
committerChristoph Brill <egore911@egore911.de>2008-07-14 20:43:55 +0200
commit2cdb4bb00b3e643abe24da83a006629435fb5c5e (patch)
tree17b3f10cabcdc96199f999deb66fa9d2c60a45f2 /src/Makefile.am
parent63d2a8ce5b34c1d98798d44842b362c4ff77d526 (diff)
Build psmcomm on *BSD systems only.
This is the second part of fixing the backend part of synaptics. The new build system is now able to detect whether it's running on *BSD or on Linux and will only build the backends that are available on these platforms. Also it will remove any reference from the built driver to the non-available backends. Thanks to Christian Schmitt for reporting.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 04be371..383bb9a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -31,7 +31,6 @@
@DRIVER_NAME@_drv_la_SOURCES = @DRIVER_NAME@.c @DRIVER_NAME@.h \
alpscomm.c alpscomm.h \
ps2comm.c ps2comm.h \
- psmcomm.c psmcomm.h \
synproto.h
if BUILD_EVENTCOMM
@@ -39,6 +38,11 @@ if BUILD_EVENTCOMM
eventcomm.c eventcomm.h
endif
+if BUILD_PSMCOMM
+@DRIVER_NAME@_drv_la_SOURCES += \
+ psmcomm.c psmcomm.h
+endif
+
bin_PROGRAMS = \
synclient \
syndaemon