summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gmail.com>2011-05-14 03:14:56 +0200
committerChristoph Brill <egore911@egore911.de>2011-05-15 21:46:06 +0200
commit39afe69ad7d2258d4043044d1283bd6e311e48da (patch)
tree0ebd3e7a95dbbc86ac8bbddd070d46759f230d2d /src/Makefile.am
parent4005df66072ceac175ea71427deb16176262f197 (diff)
build: collapse all Makefile.am files into a single non-recursive one.
With this change, the whole of the build is done non-recursively in the top-level Makefile.am. This reduces the amount of overhead due to recursing into directories only to build one file. Signed-off-by: Diego Elio Pettenò <flameeyes@gmail.com> Signed-off-by: Christoph Brill <egore911@egore911.de>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am53
1 files changed, 0 insertions, 53 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index ff513f1..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2005 Adam Jackson.
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# on the rights to use, copy, modify, merge, publish, distribute, sub
-# license, and/or sell copies of the Software, and to permit persons to whom
-# the Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice (including the next
-# paragraph) shall be included in all copies or substantial portions of the
-# Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
-# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
-# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
-# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
-
-# this is obnoxious:
-# -module lets us name the module exactly how we want
-# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
-# _ladir passes a dummy rpath to libtool so the thing will actually link
-# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
-@DRIVER_NAME@_drv_la_LTLIBRARIES = @DRIVER_NAME@_drv.la
-@DRIVER_NAME@_drv_la_LDFLAGS = -module -avoid-version
-@DRIVER_NAME@_drv_ladir = @inputdir@
-
-AM_CPPFLAGS = -I$(top_srcdir)/include
-AM_CFLAGS = $(XORG_CFLAGS)
-
-@DRIVER_NAME@_drv_la_SOURCES = @DRIVER_NAME@.c synapticsstr.h \
- synproto.h \
- properties.c
-
-if BUILD_PS2COMM
-@DRIVER_NAME@_drv_la_SOURCES += \
- alpscomm.c \
- ps2comm.c ps2comm.h
-endif
-
-if BUILD_EVENTCOMM
-@DRIVER_NAME@_drv_la_SOURCES += \
- eventcomm.c eventcomm.h
-endif
-
-if BUILD_PSMCOMM
-@DRIVER_NAME@_drv_la_SOURCES += \
- psmcomm.c
-endif
-