summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-04-17 15:19:41 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-04-26 21:00:52 +1000
commit080caee95c46bb471d1442dcab246460cad8c7be (patch)
tree4d83acc9aadd1b31dfc64d386a5730702ddf6e90 /tools/Makefile.am
parentb56ab7e0140c8fa7dcc58f6b8a087f7d6bece04f (diff)
Only build synclient/syndaemon if property support is available.
Separate dependencies for driver and synclient/syndaemon. Add option --enable-tools to explicitly build the tools (default: auto) Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index b5b12b1..35c04a1 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -18,6 +18,7 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+if BUILD_TOOLS
bin_PROGRAMS = \
synclient \
syndaemon
@@ -25,7 +26,11 @@ bin_PROGRAMS = \
INCLUDES=-I$(top_srcdir)/include/
synclient_SOURCES = synclient.c
-synclient_LDFLAGS = -lm $(XLIB_LIBS) $(XI_LIBS)
+synclient_LDFLAGS = -lm $(XI_LIBS)
syndaemon_SOURCES = syndaemon.c
-syndaemon_LDFLAGS = $(XLIB_LIBS) $(XRECORD_LIBS) $(XI_LIBS)
+syndaemon_LDFLAGS = $(XRECORD_LIBS) $(XI_LIBS)
+else
+all:
+ @echo "Not building syndaemon and synclient."
+endif