summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-05-25 13:00:04 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-05-31 12:53:27 -0400
commit2554d5b615101011c09c4786b8a18216ec0909e2 (patch)
treee6d1cdbc8187c363cfaa1b5b4b8962da3f931207 /tools/Makefile.am
parenta101621bf624466f66da41a8fa6b5ba796cd10fd (diff)
config: unconditionaly build synclient and syndaemon apps
The current conditional building of the apps was introduced by commit 080caee95c46bb471d1442dcab246460cad8c7be due to optional support properties. This is no longer an issue. There are no longer any reason not to build these bona fide apps. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index b7421fb..23b083a 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -18,10 +18,7 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-if BUILD_TOOLS
-bin_PROGRAMS = \
- synclient \
- syndaemon
+bin_PROGRAMS = synclient syndaemon
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(sdkdir)
AM_CFLAGS = $(XI_CFLAGS)
@@ -32,7 +29,4 @@ synclient_SOURCES = synclient.c
syndaemon_SOURCES = syndaemon.c
syndaemon_CFLAGS = $(AM_CFLAGS) $(XTST_CFLAGS)
syndaemon_LDFLAGS = $(AM_LDFLAGS) $(XTST_LIBS)
-else
-all:
- @echo "Not building syndaemon and synclient."
-endif
+