summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 98a14c0..04be371 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,11 +30,15 @@
@DRIVER_NAME@_drv_la_SOURCES = @DRIVER_NAME@.c @DRIVER_NAME@.h \
alpscomm.c alpscomm.h \
- eventcomm.c eventcomm.h \
ps2comm.c ps2comm.h \
psmcomm.c psmcomm.h \
synproto.h
+if BUILD_EVENTCOMM
+@DRIVER_NAME@_drv_la_SOURCES += \
+ eventcomm.c eventcomm.h
+endif
+
bin_PROGRAMS = \
synclient \
syndaemon