summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Hellstrom <thellstrom@vmware.com>2014-10-01 21:04:30 +0200
committerThomas Hellstrom <thellstrom@vmware.com>2014-10-08 12:08:58 +0200
commit576e8123d9f9f01ef6041cdfb96ca811197d05d2 (patch)
treeb45b0ea1b63beea3d11eb2d5e55bd3c3c1bf356b /configure.ac
parentde58228aaf226baac21f4bb31712f7257b221370 (diff)
Back off if we detect a vmmouse kernel driver v3
If a vmmouse kernel driver is active, vmmouse input is handled by the Xorg evdev driver and not by the vmmouse driver, so make sure the vmmouse_detect utility doesn't detect a vmmouse if a kernel driver is active. v2: Change the vmmouse kernel device name, fix comment. v3: Fix up libudev error handling. Signed-off-by: Thomas Hellstrom <thellstrom@vmware.com> Reviewed-by: Sinclair Yeh <syeh@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ad05504..1197555 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,20 @@ XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
XORG_DRIVER_CHECK_EXT(XINPUT, inputproto)
# Checks for pkg-config packages
+libudev_check=yes
+AC_ARG_WITH([libudev],
+ [AS_HELP_STRING([--without-libudev],
+ [Use to build without libudev on linux])],
+ [if test x$withval = xno; then libudev_check=no; fi]
+ [])
+
+if test x`uname` = xLinux -a $libudev_check = yes; then
+ PKG_CHECK_MODULES(LIBUDEV, [libudev],
+ [AC_DEFINE([HAVE_LIBUDEV], 1,
+ [Has libudev installed])],
+ []);
+fi
+
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.0.1] xproto $REQUIRED_MODULES)
PKG_CHECK_EXISTS([xorg-server >= 1.1.0],