summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVinay Bondhugula <vinayb@vmware.com>2008-05-21 01:36:53 -0400
committerVinay Bondhugula <vinayb@vmware.com>2008-05-21 01:36:53 -0400
commite72f4fbc61f4a0acf99a4b31f16fdebde9d339f1 (patch)
treee211ac0dc47ebd72fd669670c7ec16d43237dce4 /configure.ac
parent08f6ba03b1368e23bda4d51b16e182079fe9c409 (diff)
Don't call conversion_proc for older Xserversxf86-input-vmmouse-12.5.1
There was a bug in the Xserver for a while when it didn't call a driver's conversion_proc to convert device space coordinates to screen space. To fix this, vmmouse starting calling that method (since January), but if this is done on older versions of X, the conversion gets done twice. The fix is to add a configure check for the right versions of X and call VMMouseConvertProc() only if we are compiling against an X that has the bug. There's some whitespace cleanup for vmmouse.c too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7013426..a57851f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,7 +80,12 @@ sdkdir=$(pkg-config --variable=sdkdir xorg-server)
PKG_CHECK_EXISTS([xorg-server >= 1.1.0],
[AC_DEFINE([HAVE_XORG_SERVER_1_1_0], 1,
- [Has version 1.1.0 or greater of the Xserver])])
+ [Has version 1.1.0 or greater of the Xserver])])
+
+PKG_CHECK_EXISTS([xorg-server >= 1.3.99.0 xorg-server <= 1.4.0.90],
+ [AC_DEFINE([CALL_CONVERSION_PROC], 1,
+ [Call conversion_proc from within the driver, as
+ Xserver doesn't])])
CFLAGS="$CFLAGS $XORG_CFLAGS "' -I$(top_srcdir)/src'
AC_SUBST([CFLAGS])